通达信BBI机构进场主图指标公式(图文)

时间:2019-12-16 12:04:09 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

N:=99;M:=32;P1:=80;P2:=100;
{MY指标公式网http://www.myzhibiao.com/}
TS:=130;
MT:=3;
DA1:=IF(TSTOTALBARSCOUNT,TOTALBARSCOUNT,TS);
DA:=IF(CURRBARSCOUNTDA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1=(HI/POW(GZ,2)) AND C1(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1=(HI/POW(GZ,3)) AND C1(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1=(HI/POW(GZ,4)) AND C1(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1=(HI/POW(GZ,5)) AND C1(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1=(HI/POW(GZ,6)) AND C1(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1=(HI/POW(GZ,7)) AND C1(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1=(HI/POW(GZ,8)) AND C1(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1=(LO*GZ) AND C1LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1=LO AND C1LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SS)*3=CURRBARSCOUNT,HI*N/100,(HI/GZ),9,0)COLOR656565,LINETHICK3;
STICKLINE(CEILING(DA*L2/SS)*3=CURRBARSCOUNT,HI/POW(GZ,1)*N/100,HI/POW(GZ,2),9,0)COLOR656565,LINETHICK3;
STICKLINE(CEILING(DA*L3/SS)*3=CURRBARSCOUNT,HI/POW(GZ,2)*N/100,HI/POW(GZ,3),9,0)COLOR656565,LINETHICK3;
STICKLINE(CEILING(DA*L4/SS)*3=CURRBARSCOUNT,HI/POW(GZ,3)*N/100,HI/POW(GZ,4),9,0)COLOR656565,LINETHICK3;
STICKLINE(CEILING(DA*L5/SS)*3=CURRBARSCOUNT,HI/POW(GZ,4)*N/100,HI/POW(GZ,5),9,0)COLOR656565,LINETHICK3;
STICKLINE(CEILING(DA*L6/SS)*3=CURRBARSCOUNT,HI/POW(GZ,5)*N/100,HI/POW(GZ,6),9,0)COLOR656565,LINETHICK3;
STICKLINE(CEILING(DA*L7/SS)*3=CURRBARSCOUNT,HI/POW(GZ,6)*N/100,HI/POW(GZ,7),9,0)COLOR656565,LINETHICK3;
STICKLINE(CEILING(DA*L8/SS)*3=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*N/100,9,0)COLOR656565,LINETHICK3;
STICKLINE(CEILING(DA*L9/SS)*3=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*N/100,9,0)COLOR656565,LINETHICK3;
STICKLINE(CEILING(DA*L10/SS)*3=CURRBARSCOUNT,LO,LO*POW(GZ,1)*N/100,9,0)COLOR656565,LINETHICK3;
DRAWKLINE(H,O,L,C);
{my指标公式网http://www.myzhibiao.com/}
VAR1:=(C+H+O+L)/4;
{MY指标公式网http://www.myzhibiao.com/}
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGHLOW+0.04,4,0);
VAR11:=ZIG(3,6)REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买10 OR 买20,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买10 OR 买20,LOW*0.99,'买'),COLORRED;
S:IF(卖10,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖10,HIGH*1.02,'卖'),COLORGREEN;
DRAWICON((ZIG(3,5)REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)=REF(ZIG(3,5),3)),LOW*0.98,1) ;
DRAWICON((ZIG(3,5)REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)=REF(ZIG(3,5),3)),HIGH*1.01,2);
ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;
VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
K:=EMA(VAR7,5)*2, , COLORFF00FF;
D:=EMA(K,5), , COLORWHITE;
J:=K*3-D*2, ,COLORYELLOW;
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J10;
HS:=vol/CAPITAL*100, , COLORGREEN;
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'机构进场'),LINETHICK1,COLORFF00FF;
VAR1A:=IF(VARE0,VARE,0);
VAR1B:=IF(VAR14=200 AND VAR13=150,15,IF(VAR14=-200 AND VAR13=-150,-15,VAR16))+60;
VAR1C:=VAR1A48 AND VAR1B60 AND VAR19100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'大顶(底)') COLORWHITE;
趋势线:EMA(CLOSE,17),LINETHICK1,COLORFFFFFF;
牛熊分界线:EMA(CLOSE,50),LINETHICK1,COLORRED;
卖出:XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出LOW AND 卖出HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出MIN(C,O) AND 卖出MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出LOW AND 卖出HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入LOW AND 买入HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;
STICKLINE(买入MIN(C,O) AND 买入MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(买入LOW AND 买入HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(买入HIGH,HIGH,LOW,0,0),COLORMAGENTA;
{MY指标公式网http://www.myzhibiao.com/}
BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
上翘:IF(BBIREF(BBI,1),BBI,DRAWNULL),COLORRED,LINETHICK2;
下拐:IF(BBIREF(BBI,1),BBI,DRAWNULL),COLOR227700,LINETHICK2;
DRAWICON(BBIREF(BBI,1) AND CROSS(C,BBI),L*0.97,17);
DRAWICON(BBIREF(BBI,1) AND CROSS(BBI,C),H*1.03,15);
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*1009.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLORMAGENTA,LINETHICK1;
DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLORMAGENTA,LINETHICK1;
DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;通达信BBI机构进场主图指标公式的选股公式如下:

后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)